How to communicate with Dobot using raw protocol


Eric, I was able to verify what I have above is correct. Thanks!


Yes you’re right! I’ll send you a software to calculate the check code if you need one. Please leave your mailbox here, tks!


hi Eric,
Can you give me a piece of software to test the code I found that he is still difficult for me to understand.Thanks!


Hi lang, could you please leave your mailbox to me? TKS!


why x parameters is 00 00 7A 43 instead of 255 and how can i change the pose properly?

GetDeviceVersion response mismatch

Hi Eric,
this is very halpfull, i´m starting to understand. i need that software to calculate the check code too, can i have it, please?

This is the link for downloading this tool, hope it helps you.


Hi Eric,
I am using the communication protocol to programm and everything works fine, except the conveyor belt.
The conveyor belt is plugged in in stepper1 and with the DobotStudio it works without problems. I read, that speed is a INT worth and with the help of the tool you gave us, I tryed AA AA 06 87 01 00 01 00 42 35 but no results.
How can I start thr Belt with Protocol?


I have the same problem but also with the slider rail. Did you solve the issue if so can you share what you did?


Hi Konstantin. I connected the expansion motor (extruder) to the stepper1 of the Magician, then sent “AA AA 06 87 01 00 01 00 42 35”as Hex on the RealTerm Serial Capture Program, which can make the motor run.


Hi Wouter. Are you using the extended motor SetEMotor API in the communication protocol?
Can I see the hexadecimal result calculated by you according to the corresponding command packet format?


I have the conveyor belt working. But for the slider rail not but that is not setEmotor right? in the protocol 1.15 document they talk about a version I probably defined version wrong.

I hope you can help me with that


Determine the version of the sliding rail: You can view their labels. If label shows V2, it is the V2 version. If there is no label on the physical object, it means the V1 version.


I know how to find out what version it is but I don’t get it to work on v1 or v2 we have both sliding rails. I think it is because how you need to specify it in the protocol but I don’t know how exactly because the data type is called Version and not Int or Float or something.

Is it possible you can send me both communication strings how the define and move the sliding rail.


Hi, wouter. Here is the communication strings:AA AA 04 03 02 01 01 F9


How do you make the conveyor belt work? Could you please tell us the detailed process? Try to see if the slide rail can be implemented in the same way


It is for a work project and it is currently weekend after the weekend I will send the communication string I used.

when I am done with the project I can probably also send a java library to control the Dobot in java if you need.


OK, thank you very much


Dear wouter, please send it to my email :


for some reason it still not working it give me 2 types of return because also tried another hex value.

Your hex for Set DeviceWithl: AA AA 04 03 02 01 00 FA (Version 1 slider)
It give me the following return: AA AA 0A 03 02 00 00 00 00 00 00 00 F9

If I use the following command it give me another return:
My hex for Set DeviceWithL: AA AA 04 03 01 01 00 FB
It give me the following return: AA AA 02 03 01 FC

And for some reason the slider rail is not moving when I give it a set point can you give me a working communication string. Because I made my own but it only give a sound like the motors get power but and it don’t move or do any other commands.