Unable to connect to CR10 on setup


#1

Presently, I followed the set up instructions of both the manual and our Dobot distributor:

  1. Installed DobotSCStudio V2.2.1.
  2. Connected an ethernet cable to the robot controller.
  3. Set up the ethernet properties as shown below:
    -IP Address: 192.168.5.120
    -Subnet Mask: 255.255.255.0
  4. Tested the connection by successfully pinging 192.168.5.1 from the command prompt.
  5. Launch DobotSCStudio.
  6. Select 192.168.5.1 from the IP settings and click “ok”.

From here, the software remains stuck on the loading screen indefinitely.
When our Dobot distributor attempts the same sequence, they are able to connect without issue on their laptop.

I have tried this same process with two different laptops (all firewalls disabled), and with DobotSCStudio V2.1.8, and had the same unsuccessful result.

Has anyone had a similar issue? I am not sure what could be causing this, especially since our Dobot distributor can follow the same steps and successfully connect.


#2

You can check this document yourself first :https://www.dropbox.com/s/toown8vukfz8l6p/How%20to%20access%20robot%20using%20DobotSCStudio%20on%20Windows(CR).pdf?dl=0


#3

That fixed it, thank you!


#4

I’ll add another solution for anyone that needs it: update your DobotStudio to the latest version from their site.
I had problems connecting to a CR10 before I did just that as well.


#5

Hi!

I have the same connection problem.
After trying IP changes and enabling Modbus TCP communication, the software no longer connects to the controller.

@Hans99 could you send this document?

Is there any way to get the controller back to factory default.

Detail, I have access to it via SSH


#6

I think we can make an appointment for remote control tomorrow, which might be the quickest way to solve the problem


#7

We were able to connect via the app, which allowed us to change the IP settings.

The detail here was that the IP address and the gatware were at the same value. This did not allow the software to find the controller via the network.

Thanks