Unable to connect to CR10 on setup


Presently, I followed the set up instructions of both the manual and our Dobot distributor:

  1. Installed DobotSCStudio V2.2.1.
  2. Connected an ethernet cable to the robot controller.
  3. Set up the ethernet properties as shown below:
    -IP Address:
    -Subnet Mask:
  4. Tested the connection by successfully pinging from the command prompt.
  5. Launch DobotSCStudio.
  6. Select from the IP settings and click “ok”.

From here, the software remains stuck on the loading screen indefinitely.
When our Dobot distributor attempts the same sequence, they are able to connect without issue on their laptop.

I have tried this same process with two different laptops (all firewalls disabled), and with DobotSCStudio V2.1.8, and had the same unsuccessful result.

Has anyone had a similar issue? I am not sure what could be causing this, especially since our Dobot distributor can follow the same steps and successfully connect.


You can check this document yourself first :https://www.dropbox.com/s/toown8vukfz8l6p/How%20to%20access%20robot%20using%20DobotSCStudio%20on%20Windows(CR).pdf?dl=0


That fixed it, thank you!


I’ll add another solution for anyone that needs it: update your DobotStudio to the latest version from their site.
I had problems connecting to a CR10 before I did just that as well.



I have the same connection problem.
After trying IP changes and enabling Modbus TCP communication, the software no longer connects to the controller.

@Hans99 could you send this document?

Is there any way to get the controller back to factory default.

Detail, I have access to it via SSH


I think we can make an appointment for remote control tomorrow, which might be the quickest way to solve the problem


We were able to connect via the app, which allowed us to change the IP settings.

The detail here was that the IP address and the gatware were at the same value. This did not allow the software to find the controller via the network.



Connect your printer to your pc, open device manager and under ports look what COM is assigned, open the Creality slicer and under machine …
This makes the micro-USB cable a commonly 192.168.l.254 used cable which Creality adopted alongside their 32-bit mainboards for easy access. Therefore, you will have to get either a micro USB cable that will connect your 3D printer to your compute


How did anyone solve this? My DobotStudio Pro is searching forever. Tried two computers. I did the settings in TCP/Ipv 4 as said in the document with and sub netmask
I can ping the address with no problem and the debugging tool also seams to connect corectly.
However since I’m a Labview programmer I tried the “main.vi” in the SDK and I could run my robot from there. So the IP address seams to work. But not with DobotStudio.
I also have no luck connecting with WIFI. Same searching forever…