[SOLVED] Magician Firmware v4.0.3.6


#1

Hello,

I just recently bought a Dobot Magician.

I downloaded DobotStudio and tried to Upgrade the magician firmware but the firmware in DobotStudio is V3.7.0.0 and I don’t remember which version was before (4.X.X.X) but I downgrade it and is not working anymore.

I also try the method of usin Dobotlab and Dobotlink upgrade but the firmware inside in dobotlink is v3.7.0.3

Does any one happen to have the v4.0.3.6?

Maybe on folder: C:\ProgramFiles\DobotLab\resources\dobotlink\resources\dobotlink-win\firmware\MagicianV2\


#2

Found the v4.0.3.hex file, used the dobotlink update firmware option and now my dobot is working fine again.


#3

Hello! I have the same issue.

Can you please help and provide more details?

Where did you find the hex file?


#4

didn’t worked for me (i guess my company network blocks the connection for the update) but did you try download the last dobotlab and dobotlink?

if this didn’t worked either give me your email and I’ll send you the file


#5

Hi Jlvg89
I have the same problem, led off, tried to flash firmware but with version 3.7.0.3…no working…Could you please send me firmware version 4.0.3.6 hex file or the link to download it?
Thanks!
Mauro


#6

Same problem here. Could anybody send me the firmware version 4.0.3.6? or better yet give a link to it so anyone in the future can simply dowload it? Thanks in advance

Update: For anyone else. open Dootlink by right clicking on the icon when its runing, and then choosing “update firmware”. A popup opens and you can then connect to the robot and update the firmware. (it might be down in the tray, see image) image


#7

Can you please send me this firmware please? I give you my email