Magician Studio 1.7.0 requires admin permissions to run


After installing Magician Studio 1.7.0 on to a student computer, Windows UAC places a yellow and blue shield on the icon. Everytime I click the icon, it requires admin credentials, which is not possible for a student computer. Our group policy also requires the UAC settings to be set high and restrictive to software from unknown publishers.

I have tried several suggestions on the internet for removing the the shields, but since the student profile is restrictive, none of the suggestions have worked.

We have 11 of the Dobots at our school site.

Open to suggestions.


This is because the application is always trying to open and write to a log file, among others, located in the Program Files directory tree where it’s installed. (C:\Program Files\DobotStudio\DobotStudioDobotStudioDebug.log) The Program Files directory is write protected at the administrator level as a protection against viruses, malware, etc.

I tried running the exe from a command prompt to see if there are any soft switches that could be passed in but it doesn’t seem to respond to any of the classic help switches (-h,/h, ?, etc)

I see 4 files written to in that directory every time the application starts:

They will need to move these files to the C:\ProgramData path to correct this issue or stop writing to them.

[edit] I suppose the other option would be to have an Administrator remove the write protection on that directory but that’s not an attractive solution when presented to IT departments, and for good reason.


Thanks for the reply, brothHypertherm.
Good news, the teacher I have been helping has found was directed to an article that lists a workaround to the problem. I have implemented it on 16 lab computers and it works like a champ.



I thought I was the only one who facing the same problem in Magician Studio 1.7.0. But after reading your post, now I know it solution. I am so glad I was looking for the Edubirdie review online because my friend told me to read the review before taking help from them. I am a college student and I have got a project and for that, I need a Magician Studio 1.7.0 and every time I click the icon, it also shows me the same error. But thanks to you for sharing that article link with us in which its solution is given.