Failed to Execute Script Error


#1

Hi,

My college just purchased a Dobot Magician. We are trying to get it up and going, but every time we try to run the Dobot software, we get the “Failed to execute script DobotStudio”. Is there a fix for this? thanks for any help!

Regards,
Jeremy


#2

Please install the corresponding .exe file in the attachment folder. Note that for 64-bit systems please execute the X64.exe file, 32 bit
The system executes the X86.exe file. After double-clicking, there will be no pop-up prompts, just open studio again.
image


Help i have install problems
#3

Hi,
I also have same problem.
Even if execute “DobotStudio_dll_x64.exe”, the phenomena appears again.

FYR, my PC info. is as below:
CPU: AMD Ryzen 5 PRO 2400GE
RAM: 8GB
OS: Win10 home x64
USB: Silicon Labs CP210x
DobotStudio 1.7.1

Is there any advise? Thank you.

Best regards,
Yas Iwai


#4

Maybe you need to try to do this.


#5

Thanks!
I could use Dobot Studio.


#6

I also have the same problem but the fixes provided don’t help.

I have a Windows 10 64 bit system.

Error Message:
“Failed to execute script dobotstudio”

I have no hardware connected.


#7

Please try to update below picture drivers,from your description there is something missed when you installation.


#8

Please try to update again below red area driver from our software, we think your installation have something missed.


#9

Hey Jensen,

I have a image with windows 10 64 bit with only the following c++ 2005 installed

I have run the Dobot 1.7.1 than i ran the following attachments for my 64 bit OS:

and I ran the “DobotStudio_dll_X64.exe”

But stil the same error when I launch the shortcut on the desktop.

I’am a admin on the pc.

Should I also install the C++ x86 ?? for my 64 bit OS?

Kind regards


#10

Hello,

I have the exact same problem. I cannot open the Magician Studio, it always shows “Failed to execute script DobotStudio”. I have a 64bit System with Windows 8.2 and did all the mentioned steps above by Jensen and still have the same problem as r.nuijs.

Then I simply downloaded the windows XP Version and this works.


#11

I have made a new custom msi from the latest version with Admin Studio excluded the device drivers, installed those seperatly.

This works on all my devices in my enviroment.

I must be able to install the software on any managed device in our domain (about 5000 clients that must be able to use it). So sitting arround and wait for the devolopers with a sollution was not an option.

I haven’t got any issues reported to me yet :slight_smile:


#12

Dear r.nuijs,

Would be helpful if you share your custom MSI or indicate how you did it. Personally I did all procedures indicated here and it does not works, script error remains. I´ve 7 Microsoft Visual versions installed in my laptop and I don´t know if it is the problem.


#13

Okay Guys! Finally I solved the problem unistalling DobotStudio 1.9 and installing 1.7 version. After install 1.7 version and executes DobotStudio.exe, the dialog box “Failed to execute script DobotStudio” appeared again. So I thought … something in the operating system some program, application is blocking me from starting DobotStudio. So I created a new user in windows called “Dobot test”, I closed my session and started windows with the session called “Dobot test”. I waited for everything to load normally and clicked DobotStudio.exe. To my surprise the program started successfully and the DobotStudio´s main window with all its functionalities appeared.

Now the question is, why doesn’t it start in my regular windows session? So I did the work to go through all the task manager apps to identify differences. I noticed that the security application “Spybot Search & Destroy” was not running. I logged out and logged into my regular windows session again and uninstalled Spybot Search & Destroy … then the app asked me to reboot to complete uninstall and blah blah blah … rebooted. Click on DobotStudio.exe and now the application started successfully.

So check your operating systems and see if you have third-party antivirus or malware software such as avast, panda, mcafee or others that could be blocking DobotStudio.

The end!


#14

Had this error too. Solved.

Win10.

Find RunDobot.exe - click right button for menu and choose “fix compatibility issues” (number 3 in my case). Choose “program diagnostics” (2-nd variant). Set 3-rd box - “additional permissions are required for the program”. Next. Try to launch button in wizard. It would launch in admin mode. Ok. Done.

Before that I have try to launch it in admin mode (that yellow shield) - doesn’t work. But fix compatibility issues wizard helps.


#15

Hi folks,
same problem, even if the workflow of viskas ( thx vry much ) worked, the installation was chinese : - (
I think, dobot.cc has to solve the problem ( we have 4 dobots and we are not able to use them.
Kind regards S. Knab