Dobot Python Demo Not Working


Hi guys,

I am trying to make the robot python demo work from the Demo 2.0 folder, however, I keep getting the following errors:

dlopen(libDobotDll.dylib, 10): Library not loaded: @rpath/QtSerialPort.framework/Versions/5/QtSerialPort Referenced from: /Users/saed/Downloads/DobotDemoV2.0/DobotDemoForPython/libDobotDll.dylib Reason: image not found

I have copied the DLL for Mac files in the same folder, and I can see the libDobotDll.dylib, however it still can’t find it.

Any help would be great.



You will most likely have to compile the .dylib from the source code using qt


Did this work for anyone? Running into the same issue


Hi saed.

The cause of the error is the library refer to wrong library path.
So you need to refer to correct path.(I don’t know that this way is recommend.)

At first, you should run below code. And check the path which is referenced.

$ otool -L libDobotDll.dylib

Maybe you get libDbotDll.dylib paths contain @rpath.
@rpath isn’t working well. So you must change these path.

Second, run below commands.

$ install_name_tool -change @rpath/QtSerialPort.framework/Versions/5/QtSerialPort /Users/saed/youcopied directly/QtSerialPort libDobotDll.dylib

And, you have to run command for QtNetwork and QtCore in the same way.

At the last, check the library path the first way.


I get same error. But I cannot run the cmd you gave successful. Any other ideas ? how to get rid of @rpath


Actually it worked for me now

  1. Deleted the old Xcode

  2. $ install_name_tool -change @rpath/QtSerialPort.framework/Versions/5/QtSerialPort /Users/saed/youcopied directly/QtSerialPort libDobotDll.dylib

  3. repeat for QtNetwork and QtCore.

But seems the APIs in Python lib are diff than in Dobot GUI tool. Like Home CMD takes the arm to different location