Dobot magician led turn off


Hi there !
i’m new on the forum. My school buy one DOBOT Magician i start to work with him, in the beginning everythingh works. Now i update the firmware V.3.7.0 and the led never turn red or green sometimes in some position became blue. if i move the arm manually i can see the coordinate change but i can move with DobotStudio V.1.9.4. Please some one can help me ?

Thank you soo much


I have the same problem. Updated to V3.7.0 and my Magician no longer works. I cant get a solution.

Have you tried this:

I tried and it did not work.


i fixed the problem thanks at this web site, i hope can help people have my same problem.
Thank you soo much


These issues are caused by a firmware mismatch. You need to upgrade the supporting firmware in the software DobotLink.
Upgrade the firmwares via DobotLink software.
When using DobotLab, its driver software DobotLink must be installed. The specific operation steps are as follows:
DobotLink is the driver software of DobotLab hardware devices, you need to install and run DobotLink before using the hardware devices.
When DobotLab is started, if DobotLink is not installed or started, the “DobotLink is not started” window will be displayed, as shown below.




This is what they send to me . If you have problem just write to me


good afternoon. I have the same thing, but this algorithm did not help me. although the firmware has been updated, there is no movement


but what kind of firmware did you have Updated ?


Good afternoon.


Is wrong you Need 4.0.3 or something like that i’m not at my school . Tonight i send a screen shot for update the ring software


Unfortunately, this is the only one offered to me. Can you tell me where to get it better?


I have the same issue:


Did you try to click on select firmware at the right ?


The one that comes with DobotStudio is this:

If you download the firmware in the Download Center is this:[]=316

The one that came with Dobotlink 6.7.2 is this:

But still haven’t found the V4.0.3 firmware


did you try this first to download the firmware for 3D printer and afther select again magician firmware and is possibol him see the new firmware


Because i remember i had a trouble him diden’t saw the new firmware immediatly let me know


Didn’t work, it still show me the version in dobotlink, also if i try to use DobotStudio it would not let me connect, it asks me to install the Version.


I’m sorry i don’t know how can help you, The SW don’t give me the possibility do download the firmware . When you buy the robot ?


I bought the robot a month ago i think on Amazon.

Could you do me a favor and check by any chance if you have the firmware 4.03 in this directory?