Dobot is not working for the 1st running it up


When I follow all the instructions on the dobot, the dobot application does not do anything to the arm.

The steps I followed were:

  1. Connect all the stepper motors correctly
    2)Put the angle reading electronic pieces in the correct places
    3)Then i connected the servo correctly

Later I tried powering it up.

First I moved it to an angle approximately 45 degrees on both joints.
Then I powered it on and the motors held their positions.
And finally, i pressed the reset button.

However, now i dowlodaded the dobot v1.1 and checked the baud rate to 9600 and then I went to teach playback but none of the buttons had an effect on the arm.

I really cannot figure out what to do and would appreciate any help. I have the big black box controller.



Same problem here. I tried everything but it keeps loosing connection


it seems you make all the steps correctly. please check if the USB/wireless switch is switched to the USB end. and then reset again, and open the software and check. if it is still not working, please take screen shot and upload it here.


Do you mean it lose connection with USB?
please if the two PCBA borads(driver boar and arduino board) are not connecting tightly, maybe it get loose during the delivery. Can it be controlled with the software?


I’m having exactly the same problem. Tried changing com ports too but nothing works but the sucker button. Has anyone figured out this problem?


I met the same problem today and luckly found a way. Here is the solution.
only one image is allowed, so I split it into three part.

  1. Click config dobot button in DobotApplication1.1.1 main page

  1. Change to user input tab, input the joint angle 45, and click send

  1. Go back to home page and click teach playback

  2. Then you will see joint2 and joint3 with angle 45, now click joint + in rect zone 1, your dobot would go back to work!

  3. If your dobot get work after these 4 steps, the problem may come from the angle sensor or its connection wire.
    Hope it works !


Hey @Yan I followed your instructions on setting ‘45’ for Joint 2 and 3, but when I open the Teach and Playback interface, I don’t see the ‘45’ at the top of the joint 2 and 3 columns. It’s like the settings are not sticking.


Did you power up and reset the dobot before you send the angle 45? If not then it will behave like this, I have checked this with my dobot.


I am also facing this type of error on my iOS. This type of problem is really very annoying and it is happening after updating the firmware. The main problem it is showing is iTunes error 9.