Dobot does not move


Hi Guys,

i followed the setup. Switched on the power and nothing happens.
Terminal gives me “¥é ©C¶:§C¥¶:§CA¥¶:§C¥¶:§C¥¶:”.

Please help :slight_smile:


I’ve done the sensor calibration. It worked. I hoped to get it going if the sensors check, that the arm is in a good starting position. Well it doesn’t change anything apparently. No movement control with any input from the interface. The only thing which works right now is the on/off of the suction pump.


Please let us know the version of application and dobot(Date of purchase) you are using.
The upgrades are available on our website:


Same problem here, i updated to the newest firmware and software but my arm still haven’t worked since i received it in febuary


I had and still have problems getting my dobot to respons to input from the application 1.11.
I got it to work by changing the baud rate to 9600 - restart the program and change the baud rate to 25600 and restart the program again and then it works.

Ones the program works it works till I turn off the dobot.

Hope it helps.


Same problem here.

Purchased Dobot 1.2 one month ago. Updated firmware to v1.2 successfully, put Bluetooth module into command mode and updated that successfully too.

Downloaded v1.1.1 of DobotApplication and set the baud rate to 9600 and restarted the program. Even tried setting the user input values for joints 3 and 4 to 45 as mentioned in another thread, but still no movement.

Tried moving dobot via Bluetooth on iOS, it seems like we are enable to connect because the Bluetooth light goes solid. However trying to move the dobot results in failure.

Starting to get frustrated here, so any advice would be very helpful.


One more thing, the dobot is in correct starting position of < 45 for the joints and we did press the reset button before we opened the application


Seems you’re doing correct, don’t konw which part is wrong. All I do is put the arm in the correct angle, power up and reset it, then open the Application V1.1.1 and I can control it. Maybe you can try the latest firmware here, it’s Dobotfirmware.hex file, you can refer to this link to upgrade it:


That’s the firmware that we used, v1.1 is currently available for download in the DobotTools package. Any other ideas? Wondering if we received a bad arm? Couldn’t even get bluetooth mode to work…


Hi, Roykolac, sorry for the trouble.

Please try to use the DobotTools1.3, power up your Dobot and run the software, and if there is some detectable error, it will give you an notice and some tips to solve that.
if the problem still can not be solved, please give us some picture about your Dobot and the screenshot of the software, we can determine the problem


Just to confirm, the DobotTools 1.3 package contains firmware version 1.1, correct?


It’s the hex file named “Dobotfirmware.hex”, not V1.1.


I too can’t get bluetooth to work. Or the wifi. I have to have it manually plugged into my computer via the USB because it doesn’t want to cooperate any other way, and I went through all the steps in the manual. Wondering if the bluetooth and wifi adapters are bad.