Mooz 2 3D printer not working


I received my Mooz 3D printer, set up and turned on. The unit powers up, the fan spools up and although the keypad works (I can move between screens) nothing happens when I press any button.
Instructions start with setting Z…done by home then the unit should reset. Mine simply keeps spinning the fan but nothing moves. Help


I am the user of a 3D printer for my office and I bought it a few months ago it has multifunctional (print + scan), works offline also. I let you know at the time of set up I had the same problem I did many things to slove that but I couldn’t then I contacted RICOH and they shared some tips with me Ricoh Printer Offline to solve that problem then I could it myself. I would recommend you can get help from there it might solve your problem.


I have both a Mooz 3D printer and a hp printer. My Mooz 3D printer was connected with my computer earlier. So when I tried to connect my hp printer, I faced an error that occurred at that time. I learned about after searching many websites and solved my hp printer problem. But after that suddenly my Mooz 3D printer stopped working. What should I do now?


My Mooz 2 3D printer also not working. I really want to know why it is not working because I have got only two days to submit my project. I was also worried because, in these two days, I have to submit my assignment but thanks to one of the great paper writing websites who helped me in submitting my assignment. Does anyone here is expert in Mooz 2 3D printer?