MG400 WIFI Settings


#1

Greetings

On the DobotStudio, there’s an area for Wifi settings where I can put an SSID and a password, which I assume it’s to connect to that network.
Even though I’ve done that, my Dobot still doesn’t show up on the network (the SSID and password are correct)

However I’m not entirely sure the MG 400 is even capable of Wifi so I’m not sure why that option is even there.
Could this be clarified, please? Can I use Wifi with MG 400?

I’ve also tried to connect a Wifi dongle to an USB port in the back of the robot, but it doesn’t seem to be working either.


#2

Hi David, it would be helpful for us to locate if you can provide a screenshot


#3

Here’s the backside of the Dobot and where I have the wifi adapter connected, a generic TP Link dongle.

According to a few emails I’ve received, the MG400 does not have wifi capabilities on it’s own, but supposedly it should work with a wifi adapter much like the CR, however clearly I’m doing something wrong since the adapter shows no signs of even being used (a small green led inside) when connected to the Dobot.


#4

For clarity sake, this is the wifi adapter I’m using as well. From what I’ve seen, the CR uses a similar one for wifi and supposedly the MG400 can do the same?


#5

Hi David, please follow the steps below to try:

  1. Connect the Wi-Fi module as well as the ethernet cable to your computer, connect MG400 in DobotSCStudio and set up the SSID and password settings
  2. Then remove the cable, restart the machine, connect your computer to the SSID you just set up in step 1, and then you will be able to connect your MG400 wirelessly.

If still you cannot make it happen, please send a video of how you operated to support@dobot.cc so that we can help you to locate the problem


#6

I have tried those steps, still unable to connect.
The activity LED in the Wifi Adapter doesn’t even light up, so I’m not sure the Dobot is even using it despite being connected to the USB ports.

I’ve sent an email to Support with a link to a video of the steps I’m going through.


#7

Hi David, I believe my colleague replied you via email. It could be the reason that the Wi-Fi module is not supported. Please check your inbox and let us know if you need any further assist.

Here I uploaded the guide on how to use WiFi to connect MG400 on Windows so other users can download when needed: https://drive.google.com/file/d/1nVMBkJDLjgaJJyW5xvNeW-KjZ396UQQk/view?usp=sharing


#8

Problem solved. Just to give an update for anyone that ends up in a similar situation in the future:

The issue is that the Wifi Adapter I was using, TL-WN725N, could not be set as “SoftAP” or “soft access point”, therefore the robot could not broadcast a network using it.
I will try to get a different adapter like the TP-LINK Archer T3U, which I believe can actually work.

Thanks for your help in narrowing the problem down.