Upgrading to Cura 3.3.0


Has anyone tried upgrading Cura to the latest 3.3.0?
Any improvement?


Continuing the discussion from Upgrading to Cura 3.3.0:

Yep, tried too twice. Once for 3.3.0 which immediately said there was a 3.3.1. Neither would send the print via the USB connection I use with 3.2.1. Hence, reinstalled 3.2.1.


I’m using Octoprint on a Raspberry Pi and Cura 3.3.1 with the Octoprint plugin. Works like a charm with the added benefit of not having to plug in the computer or walking back and forth with a SD card.


How did you get OctoPi working? I’m unable to connect via USB from my Windows 10 PC or OctoPi. I’m wondering if something is wrong with the USB interface. When I plug in the USB cable, the printer makes a couple of beeping noises, but I’m unable to establish a connection to the printer from Cura/Windows 10 or OctoPi.


I didn’t do anything special, just plugged in the usb in my Raspberry Pi and Mooz and clicked Connect in OctoPi. So not sure why it’s not working for you. Sometimes, after I switched off the machine and OctoPi loses the connection is hard to get the connection working again, but normally, rebooting OctoPi works.