ROS 2 Compatibility


#1

Hi Team,

I’m wanting to build my systems on the the new ROS 2 platform, not ROS 1. Does Dobot Magician work with ROS 2? If not, how can I get it to work with ROS 2, and what would any pros/cons be?

Thanks,
Scott


#2

The pkg we can provide for the time being is under ROS1. If you want to use ros2, you need to modify and adapt pkg according to the instructions of ROS official website.