Regarding:firmware update


i have updated my firmware version to v 3.3 after that Dobot is not working and too i am not getting port indication to connect with my pc. could you suggest me what to do further.


I am also having problems getting the dobot to update the arm the newest firmware. 3.6.10 it loads then doesnt allow me to connect after.

I tried to restart it then shut down program shut everthing down and restart. still no luck. Is anyone else having issues getting there arm to connect after installing the 3.6.10 update


The fix for me was to just keep doing it. I shutdown pc then restarted the program and just kept reseting dobot and trying to update the firmware over and over.

I feel like the rail I have attached has something to do with me having issues. I hope they are testing all there updates with the rail system, no rail, and any other attachments or hardware that attached to the dobot arm.

These firmware updates scare me. One day I did it with an old mac and my mac just broke and now I cant use it. :frowning: be carefull with installing updates guys, if you have a bid demo or something like that best to wait until aftert the demo to install any firmware updates.