Problems using RAW protocol with Dobot Magician



I have this weird issue that if I send a simple command trough the serial port, like AA AA 02 0A 00 F6, it sometimes works but sometimes it doesn’t. I used a snif on the serial port and can see that when it does work th magician is returning nothing or sometimes FF.
If I shutdown the magician and turn it on again it might work. Seems like it works 1 out of 10 always with the same command
When it doesn’t work then I can’t even connect with dobotStudio until I restart the magician.
This problems doesn’t appear if I use just the dobotStudio…it is like the sending command lock the dobot.
When sending the command works then I can send other commands or the same several times and it always works until next restart.
DobotStudio always work after a restart but sending the command getPose trough serial port doesnt.
I have tried to connect first with dobotStudio, then disconnect and then send the command, but same result, it works 1 out of 10.

Any ideas?

Edit: it works fine on my PC but not in some others PC, same code same program same everything beside the PC itself and characteristics of the PC (processor and so on)