Not connecting to software


I recently purchased a dobot magician. It was working well on my desktop computer but when I tried running it from my laptop I ran into a lot of problems. The arm would not connect to the software and began to lock up when I tried to reset it. Now It will not move at all when I press the unlock button and I only get a red light when I try to reset the system. I have no idea why it suddenly stopped working but it seems unusable now. I don’t know what is wrong or where to start to fix it. any advice would be very much appreciated



I rebooted the firmware and was able to connect the dobot to the software again, however when I try to calibrate the arm it jams and locks up every time


I ran into an issue with a desktop that doesn’t like to communicate with the Magician, while my laptops do. I suspect it has to do with insufficient power at the USB root hub. On occasion, I can overwrite the firmware on the Magician on the problematic desktop, and it works until I shut off the arm. I will attach a powered hub to see if the issue changes.

In the meantime: Is your LED red or orange? Big difference. Also, make sure your arm isn’t too retracted when you power it up. Otherwise, it’ll consider itself out of range. Keep the joints close to the home position, with the arm somewhat extended. Keep it unplugged from your computer. If it comes on and turns green, your arm should be working correctly. If it’s still red even with the arm in a normal position, then you may have an issue with the arm.

I myself had to add lithium grease to all the rubber-insulated cables in the top of the case (base of robot) - they like to rub up against each other, create noise, cause friction, and result in the binding of Joint 1 after about 90° of rotation. After adding the lithium grease to all the right points, the arm is quiet, and can rotate to all its positions as expected.

So, in summary: Extend the arm a bit, unplugged from your computer, and power it up. If light goes from orange to green after about 10 seconds, the arm might be okay. If it’s still red, there may be a different issue. Do reach out to support via e-mail, they are quite responsive.


hi, how do you reboot the firmware?


DobotStudio -> Settings -> Firmware -> Dobot firmware. If you are connected with arm, then some kind of “burn” button propably will appear (curently I’m not near my arm, so i can’t check it in 100%).