Need help running python script on linux (arch 64 bit)


I copied* into /usr/lib (and also to directory with python files), but still getting failure during library load:

File “”, line 11, in
api = dType.load()
File “/home/asyrov/dobot/sdk/DobotDemoForPython/DobotDemoForPython/”, line 462, in load
return cdll.loadLibrary(“”)
File “/usr/lib/python3.6/ctypes/”, line 418, in getattr
dll = self._dlltype(name)
File “/usr/lib/python3.6/ctypes/”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: loadLibrary: cannot open shared object file: No such file or directory

Can anyone please help me how to resolve?

Thanks a lot in advance,


Still waiting for customer support to resolve the issue. Promised source files are missing!

Here is what company declares:
“This package includes Dobot Dll files(win 32&64), Dll source code, precompiled Dll for Linux and several kinds of Demo”

Now, “Dll source code” is missing, while included in the price of the device (for me).

Please fix the issue and include files you promised!
Thanks you very much in advance,


I received requested sources. Thank you dobot team for the great product and prompt support!


Hi @asyrov and dobot team,

I have a couple of follow-ups. I’m trying to run from my 64-bit Ubuntu:

  1. How were you able to get the 64-bit version of We you able to run
  2. The source code seems to be provided with the latest version of the, but how do we compile it? What do we get as the output? There is no documentation provided with the zip file

Thanks a lot!

Best regards,


My system is Arch Linux 64 bit. It should be similar to Ubuntu 64, except that Arch has usually more up-to-date packages (for instance my gcc is now 7.2.1 and yours is probably lower). I think this may be important because Dobot library has dependency on QT which may also be of different versions.

To your question: (1) Yes I was able to run from 64 bit version of python 3.6 on my Arch.

(2) does not contain sources for library (it has prebuild libraries, but not sources, at least I could not find them). I would recommend if you cannot run provided libraries contact support through e-mail and ask them to send you sources, so that you can build them locally on your specific system.

Hope it helps.


I have exactly the same problem and I cannot continue with my application.
In windows the script works without any problems.
How can I solve the problem?
Thanks in advance.


loadLibrary erro fixed? how?


I am also facing the same issue, python demo is working in the windows without any problem, and couldn’t run in linux. please help us giving steps to be followed or any help is appreciated


Hello all,
I am also facing the same issue. Exact same error.

I am using Debian 10, with Python 3.7.3 x64.

Also, I downloaded the which is the most recent (3/2020) and did it 5 days ago (5/2020).
What I am not sure (because you had such issues 1-2 years ago and I believe the files have been updated/upgraded since then) is if I am missing something, or if I am running something wrong.

What I did is:

  • Copied the files and in a folder
  • In the same folder I copied all the files from DobotDemoV2.0\DobotDemoV2.0\DobotDll\Precompiled\Linux

Then, I run the while inside the folder that contains all the files that I mentioned.

So, is something missing?
Am I doing something wrong?
There is also a folder with source files (different from precompiled). Would it be better to compile these?
If yes, how am I supposed to compile them?



Hi, I have a same problem, i need the for linux 64-bit, can you share with me?. please!