Mooz2 not reading sd or udisk


Hi, I ave a new mooz 2 set it up went to update , said was up dated - ok updated the touchpad , now the sd card or the udisk will not read any files, tried re updating firmware by incimenting the # the touchpad just says sd card ok - will not update or read any files



I have the same problem SD card reader will not read any SD cards. I have verified that they are FAT32 formatted and are less than 32Gb. I have tried with only one single file on the SD card, both GCode file and a Update for the touchpad but nothing shows up.


There can only be one update file in the SD card. First, determine if the firmware has been updated successfully. All gcode files and update files can only be read in the root directory.


In my case i have followed the these rules:

  1. Only one update file at a time in SD card
  2. files located in root directory
  3. SD card FAT 32 16GB
  4. Model files in the root
  5. 1 or 2 model files on the SD card does not make any difference Mooz does not read anything.