Magician 3D printing Z coordinate not consistent


Hi I’ve been using my Dobot Magician for about a month now and so far it’s been doing very well and getting very familiar with it. But lately I’ve been trying to 3D print but haven’t been able to get a successful print. It looks like the Z coordinate raises and lowers with the X coordinate, X+ raises Z while X- decreases Z. I’ve tried using the auto leveling attachment but it didn’t make a difference probably because it’s a different firmware. If anybody has any ideas or has had a similar issue any help is greatly appreciated!!! Thanks for reading and hope to get this solved!!!

I’ll try to get a video of it soon and post it to YouTube and I’ll put a link in here.


I had a similar problem and solved it by leveling the dobot and the glass plate really carefully. You might need a bubble level or some really accurate leveling tool. Once everything was level (dobot and glass both perfectly level) I had much better results.


Hello there.
Might be a bit late but in case you over took the given example slicer settings the “vase printing” option could be enabled. This option raises Z with the time while printing. For normal prints make sure it is disabled.


Thanks for the replies upoils and Gero_S, I will give both a try both seem very plausible for my issue.