M1 IP Connection Failure



I am trying to upgrade my Dobot M1 firmware. However, I am unable to connect to the Dobot using a network cable. I have manually configured the IP over a USB connection to be on the same subnet as my PC, but after disconnecting the serial connection, I am unable to see any IP connection options.

Is it possible to update firmware using the USB connection?
How can I properly connect to the Dobot over IP?

Thank you!


Hello Matson,

I had issue too making the connection via network cable. However my brother is fantastic on computers and talked me through. My issue was obtaining the correct IP address. If yours is the same I can talk you through how I over came that?



Hello Richard,

I would love any tips you could provide towards obtaining the IP address. The steps I have tried are:

  1. Connect to M1 over serial (USB) cable
  2. Select correct COM port in M1Studio and click ‘Connect’
  3. Select ‘Tools->IP Address Setting’

My issue is that once I have this IP address, I don’t know what to do with it. There is no way for me to manually specify a connection IP address. Any help would be greatly appreciated!

Thank you,



1, Find out your IPv4 address for the computer you are using.
2, Connect the M1 via the USB cable and also connect the ethernet cable to your computer, then turn the power on to the M1.
3, Open the M1 Studio and enter your IPv4 address into the IP address settings but change the last 3 digits so that it doesn’t match the computers IPv4 address, and make a note of it. Save the settings. This will now be the IP address for the M1. The last three digits can be anything.
4, Open up a web browser and enter the IP address for the M1 into the search bar and press enter. You will then see the web manage page for your M1. You can update the firmware from here.

It is worth reading the firm ware instructions on the Dobot web page. The firmware needs to be installed in a certain order.

Once you have updated the firmware, you can just use the USB to control the M1

I hope this helps.


Hello Richard,

Thank you very much for these steps, that worked perfectly! I am still having issues homing the robot, but I believe this to be a separate issue.

Thank you,


Hello Max,

Brilliant. The ‘thanks’ really goes to my brother, he talked me through it.

My M1 doesn’t seem to work since the firmware updates. When commanded to move by Blockly and teach and play, the arm moves down a few mm and first joint moves right by 10mm and then stops. It does this each time. Have you had any similar problems?



Hello Richard,

I have not had that issue, but I am not using Blockly to perform the movements. I am loading a Python script into M1Studio and commanding it through that. My issue is that the M1 usually fails to home. However, when it is successful the robot moves correctly. I was hoping that updating the firmware would resolve the homing issue but it does not appear to have helped.