Laser engraving just stops for no reason


#1

I just had my magician arrive a couple of days ago and set it up yesterday.

I don’t have a massive amount of time to have a proper play with it until the weekend, so I figured the laser engraving head would be something fairly simple to deal with for now. I’ve figured out my Z position, focus, and power for what I want to do, but I’m having a problem.

The engraving often just seems to stop for no reason at all. There’s no error message (unless it’s recorded in some log file that I don’t know exists) or warning that pops up, nothing. It just stops.

So far, in several tests I’ve had it stop anywhere from 37 seconds all the way up to an hour after I tell it to start. Most often it happens 20-35 minutes in A couple of times it’s gone all the way without issues, including a three hour one I left to do its thing when I went to bed last night.

But now, again, today, it gets an hour into an etch that looks way better than I expected it to and it just stops.

Anybody have any idea what may be causing this?


#2

Fourth time on this test piece now, died after 53:56 without warning or reason.


#3

Well, turns out there is a reason. The Escape key seems to be a global hotkey to kill the laser, even if Chrome, Photoshop or something else where I might commonly use the Escape key is the active application and not Dobot Studio.

I don’t see an option anywhere to change this behaviour in DobotStudio v1.4.15. It would be nice to be able to continue working while the Magician’s doing something. :slight_smile: