J4 axis does not turn


#1

Hi there!

I´ve suction cup mounted and J4 axis does not work. I am testing teaching & playback and when I push the buttons J4+ J4- R+ R- it does not turn, related numbers increase and decrease in DobotStudio but phisically there is no movement.

I´ve tried to fix it restarting the software and Magician, I did auto levelling, I checked firmware and it has the latest. Then in DobotSudio after all put Magician en home position, I selected Suction Cup in upper selection field, I opened Teaching & Playback, I pressed buttons J4+ J4- R+ R-, Magician J4 axis remains motionless.

What I can do?

Best regards!


#2

Hello!

I found solution here in forum. @jlim wrote a reply fixing the problem (Dobot Magician -Rotation axis of suction cup / gripper not responding )

"when you said you plugged the rotating servo to GP3, did you plug it to the port labelled 1 on the arm?
Maybe can double check, because GP3 is actually the first port nearest to the rotating servo, and NOT the one labelled 3.

If all the connections are correct, maybe one other troubleshooting step is to connect using the user friendly Dobot Studio and to use the GUI to set the rotating servo to rotate (teaching and playback > then set R to any non zero value). If it works in Dobot Studio, then the issue may probably be in the python code. If it does not work even in Dobot Studio, there may be an issue with the way your wires are connected. (in that scenario, a photo may be useful for others to try to help to troubleshoot)

Hope it helps."

Thank you @jlim for your post!