How to make the Mooz work right with 3d printing


#1

If you’re reading this you’ve been getting bad prints out of your Mooz.

First off bed leveling. The bed leveling used on this treats the bed as a slant. My bed is warped so it does me no good whatsoever and will be turned off with M420 S0. My fix uses the old reprap hide your mechanical shame with a raft method of 3d printing. I’m using a bed that they sent me for god knows what reason when I ordered some bed stickers a while back. I should see if the original one is warped.

Next glaring issue is the fact they got their steps per mm on the extruder wrong. How the actual $^@& is that possible on a machine that made it to production and has had multiple firmware updates? On that did you Dobot people mean to upload V1.4.5 on 1/17? You sent an email saying there was a firmware update, well, we’re waiting!

Final oopsie is the bottom left of the bed defaulting to 2.5, 2.5 which means on the off chance you’re printing over at 0, 0 then you’re printing in air. This might be right on the default settings. I have no idea if the machine saves any settings or what. Which would be crazy if it didn’t because it has like 2mB onboard storage. But then crazy fits here. And to think if they spent like an afternoon they could have Marlin 2.0 on this thing and be moving units. But nah we’d rather fancy ourselves some new hot stuff then benefit from GPL code. Who wants someone else to do the work for us? That’s just crazy! We’d much rather have angry customers.

Main fixes:

M200 D1.75
M200 D0;just in case you’ve messed up your diameter or turned on volumetric
M92 E96.2752;fix steps per mm - is MK10 clone so using MK10 steps per
M420 S0;bed is warped slant leveling won’t help hyere
M206 X-2.5 Y-2.5 Z; might be right from the factory - probably not though

On the last command that Z should correspond to where the nozzle actually touches the bed. -4.8 might work for you, it might not.You want to use a 0.3 first layer on rafts if you want even the slightest change of this thing working right. Making the number more negative raises your nozzle’s position when you send it to zero. Making the number more positive lowers your nozzle’s position when you send it to zero.

Anyway open up a terminal my goto 115200 is the speed:

https://realterm.i2cchip.com/

Send it M206 X-2.5 Y-2.5 Z-5.0. Then use G0 Z2 F1600. Then G0 Z1 F1600 etc etc until the nozzle is just touching the bed. Try not to break your printer here. From there you will see it either stop at a negative or positive value. Subtact that value from your -5 value you started with. Use G0 Xxxx Yyyy Z5 F1600 to go around the bed and get a general feel for where the highest point is. That is where you want to set your Z offset. And yes you want it touching the bed at 0. And I mean just touching. Not into the bed, or with a paper sized gap, touching the bed. No paper under nozzle or any of that time wasting.

Then in cura you want to use a 0.3 first layer with a raft and you can print all over the bed at the same time.

A note, Cura did a weird thing where the material got stuck on 2.85. I went to 2 nozzles then back to one and it worked. It also did that for the heated bed. I checked and unchecked it and it worked. I blame windows.

M200 D1.75
M200 D0
M92 E96.2752
M420 S0
;make sure to get your own value here. Don’t be sad if you just try these values and ruin your bed
;M206 X-2.5 Y-2.5 Z-4.7;for outer prints
M206 X-2.5 Y-2.5 Z-4.8;for center only prints squish the raft a little less
M104 S{material_print_temperature}
M140 S{material_bed_temperature}
G28 ;Home
M190 S{material_bed_temperature}
M109 S{material_print_temperature}
G1 X-2.5 Y-2.5 F6000
G1 Z2.5 F1600
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0

I had some really tuned in acceleration and jerk values from before this thing went to hell on me. I’ll post them here along with the tuned PID settings if I can dig them up. Hope this helps somebody. Unless you work for Dobot then I hope this doesn’t help you.

Dishonoring the GPL brings you bad luck.


#2

OK I tried the old bed. It is not warped. That means the 3 point slant leveling works. It’s worth noting that to have a model for the center of the bed print at the center you need to make the build plate in your slicer 135 by 135 even though the bed is 130 by 130. If bed leveling is working for you then you can skip all the raft stuff and M420 S0.

In cura I use 1.25mm retraction with 50mm/s retract speed. I use a travel speed of 150 and use the default settings on acceleration and jerk control. To make acceleration and jerk control work with the Mooz you will need this to start your g code:

M200 D1.75
M200 D0
M201 X6000;set max accs
M201 Y6000
M201 E10000
M203 X250;set max feed rate
M203 Y250
M203 Z10
M203 E100
;best to use acceleration and jerk control in Cura
M204 S3000;set acceleration
M205 X40;set max jerks
M205 Y40
M205 Z0.4
M205 E5
M92 E96.2752
;ONLY USE IF YOUR BED IS WARPED
;M420 S0
;M206 X-2.5 Y-2.5 Z-4.7;for outer prints
;M206 X-2.5 Y-2.5 Z-5.0;for center only prints squish the raft a little less
M104 S{material_print_temperature}
M140 S{material_bed_temperature}
G28 ;Home
M190 S{material_bed_temperature}
M109 S{material_print_temperature}
;G1 X-2.5 Y-2.5 F6000
G1 X0 Y0 F6000
G1 Z2.5 F1600
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0

I am able to get nice prints with either bed and these settings, though I’m going to stick with the one that is slanted and not warped.