Firmware Upgrade Issues



I have been in contact with support via email since April 17th. The last message sent from was on May 16th and I was unable to reply until recently. My recent reply sent to was sent on November 25th and have not received a reply yet. After looking at the website it appears all support has moved to the forums?
I have uploaded the email to my Google Drive if you care to download it and read it, the link is as follows:

I have also pasted the conversation below so that we don’t have to go over any steps that I have already tried. I have put my messages in bold and the replies from in italics

I am a kickstarter backer and recently tried updating the firmware on my Mooz 2 and now it will not start up. The LCD screen just sits there and never moves past the "starting….” screen.

My kickstarter info is as follows:

Username: Jerimiah Milton
Pledged $509
$289 - Early Bird: Mooz-2
Added $79 for laser module
Added $79 for CND module
Shipping $62

Hi, Jerimiah

This is a video for teaching you how to update the frimware

If it still not work after the right operation, Can you take us some video or picture materials which you think able to help us check the problem?

It is easy for us to identify the problem and provide fast and correct after-sales service.
By the way, I wanna know the S/N number at the bottom of the base for quality management.


I finally had a chance to go through the steps and record the outcome.

After watching the video and going through the steps it’s still unable to start up. I am also unable to update the firmware on the LCD touchscreen. Please find the video attached.

Also, the S/N of my Mooz is MZ21-1712-1005


Sorry for replying you so late, since the business trip and the public holiday.

The mainboard frimware is same as the Flash drive one, So the system won’t update the frimware at that time, You can try different vision.

The 1.5.3 is the lastest bete vision. you can update it if you want.

_By the way, You need to update the mainboard and control pad seperately. _

Hope it can help you.

Attached was MOOZ2V1.5.3.bin and MOOZ2V1.5.2.bin


I’ve tried both versions you sent and both of them upgraded the printer, but after the update it did the same thing.


Please make sure there is only one frimware file inside the sd card or flash drive.

Cause you know the automative updating only can identify one file.

That’s why I tell you update the frimware seperately.


Yes, I did that. I recorded the process. Please ignore my wife freaking out in the background of the video.


The video looks like the updating operation is success,

How about the LCD pad frimware update.

Yes, I tried to update the LCD firmware and it’s still not working. Also, even though the mainboard firmware had updated, the printer will not start now. It stays on the screen saying starting…


Your USB flash drive may have hidden files, which are not visible to Mac systems.

Can you trouble format your USB flash drive and try to update the frimware again?

_So sorry for this problem, We will update the frimware updating operation easily. _

Hope to get you understanding

I finally got around to working on this more. I have purchased two new SD cards, fresh out of the package and am still unable to fix my printer.

Please find the video attached.