DobotClient_JOG not Moving Robot


Hi Dobot team and community,

I’ve recently been trying to get my Dobot Magician to work with ROS, and am most of the way there. I have roscore running (and properly configured), and rosrun dobot DobotServer /dev/tty is running fine. My problem is when I run rosrun dobot DobotClient_JOG. The program seems to run fine (e.g. no errors) but won’t actually move the robot. I’ll tap a letter, and it’ll wait for about 2 or 3 seconds, and then post some numbers and “Result: 2”, whatever that means. See attached Screenshot 1 here. I’m working remotely so I’m VM’ing and watching my Dobot on a webcam.

I know the serial communication is working, because I installed “cutecom” to talk to the Dobot at a low level, and when I tell it “aa aa 03 1f 00 00 e1” it will successfully cause the Dobot to move/home. For some reason this forum will only let me attach one image since I’m a new user, so here’s an imgur link for this image.

I’ve also tinkered with the ASCII characters, though I don’t think that’s the issue. I’ve found vague mentions on other forums of this ASCII mapping being the cause, but if so, how should I figure out what to map these values to? The program seems to understand when I’m typing one of those keys vs. a non-mapped key. Imgur link here.

If y’all could help me out here, I’d sure appreciate it. I’ve been having a ROUGH time getting up to speed with Linux/ROS/Dobot, as a generally computer-illiterate person haha. Thanks in advance!


Hey, I think you might want to try the specific port of the Dobot is connected to, e.g. ttyUSB0 (replace the number 0 with the actual index - use ls /dev -l to see which specific port to use).
Btw, I’m also trying a lot of things with Dobot and ROS, let’s connect if you want to -


Dear sprombo, if you still get an alert from this thread, would you mind sharing your Dobot ROS files (including the URDF)? I too am trying to simulate the Magician in Gazebo, and then move it from ROS MoveIt!