Dobot Studio cannot be installed


Trying to update DobotStudio is not possible on both Mac and PC. It would be better if the software was put on the Mac Store, otherwise it’s very difficult to install. After managing to get v1.6.7 on the Mac, the entire language switched to Chinese. It freezes and I was unable to connect.

Windows v1.6.10
I tried installing on Windows 8 and Windows 10, and similar security issues occurred. I was unable to install the software because it was untrusted and will not let me.


Same problem here. Can’t even Install on Mac. Software crashes in the setup.


I’ve fixed this since. Switching to English was simply scrolling down the list of languages. Luckily I had another copy on Windows to find that it was next to the envelope above settings. I had to update CH34 and the USBDriver which did the trick.


Ugh! But now I need to install on Windows to update firmware. Window software crashes in setup.


Connecting DobotStudio v1.6.10 to Windows a success after turning off tutorial and updating to Windows 8.1. After re-installing drivers CH34 and CP210 (which fixed my Mac issues) connecting to Dobot unsuccessful. Not sure what I can do from here.


Same problem here with Mac running 10.14.4 is there a solution after allowing the installation in the security settings it doesn’t finalize the installing proces.


I also facing the same situation when I tried to update new version of Dobot studio it shows an error itunes sync error 54, so I really want a solution how to remove this error also want an instruction how can I install the new version.