Dobot Mooz 2 under Linux Mint 19 with Simplify3D 4.1/CURA 3.5.1


I want to operate the MOOZ 2 under Linux Mint 19, using Simplify3D because it is the only software which offers implemented compatibility to the MOOZ 2.
But after installing and printer setup I can’t establish a connection although the MOOZ 2 is powered on and connected to the USB port.
So I tried the CURA 3.5.1 as described in the manual, did the settings as described and tried to establish a connection. Same result as before: no connection.
My third and fourth tries were to install CURA 3.5.1 as well as Simplify3D 4.1.0 on a Windows 10 machine. But after setting up the results where the same as under Linux Mint 19: I couldn’t establish a connection.
Both softwares try to establish a connection via textual, binary and alternative communication protocols without access.
Does someone has an idea what’s going wrong?


(By the way: printing via SD card works. But this couldn’t be the solution. Hopefully a haven’t bought a piece of unusable metal…)