Dobot Magician V3.7.0 Broke Dobot. Bricked, status LED not working Dobot Not working


#1

As the title says, since updating my Dobot Magician from Dobot Studio to V3.7.0 my Dobot no longer works.

The status LED is off, it does not turn Red or Green but the arm does not move. I can connect to it from Dobot Studio, and can get it to log coordinates on the teaching & playback with the manual teaching, but the playback does not work.

I tried following the steps to us the Mcuisp to reflash the firmware of the dobot but that did not work either.

Followed these guides here:

and here:

But it did not work. How can I make my $2000 machine work again? It is a paper weight right now.

I have tried emailing support@dobot-robots.com and they responded one time asking for more information but will not respond anymore.

Thank you.


#2

Hi! I got the same problem with you, and I was able to fix this by using the Mcuisp software. I did have to change the “baudrate” to match the usb interfase though. mine was 9600. (Mcuisps default was 115200). I found out the correct baud rate by going to “Device manger” with the bricked dobot connected, then look for the USB device with the name “silicon labs — something something (COM5)” and look at the Properties-> port settings -> Bites per second.

Good luck!
Paul from Norway


#3

I have the same problem. Changing the bite rate did not change anything. I want to add that the motors on the side do get warm. When I use the playback in, I can see that the program thinks the robot is going to the coordinates but nothing happens to the actual robot. When i turn it on there is a short (less than 1 second) red flash. It then goes off with no light. Any fix to this or other suggestions?