Dobot Magician 3D printing - Red led


Hello everyone,
I tried to do some 3D printing with the Dobot Magician. However, it appears that the led is red once the 3d printing firmware is burned. From this website:

It appears it might be due to a bad temperature sensing. Once the repetier host software is open, the temperature is shown to 0°C. Any idea how to solve this?
Best regards,



well, the red light within the 3d software is mostly a sign for a failed connection. the shown temperature of 0°C is also a sign for a missing connection to the dobot.
have you checked if there is an update for the 3d software?
althought for me it worked the best as i set the software back to the version like in the manuel guide.

also, after you burned the 3d print software, close the dobot software and start the 3d print software stright away without the dobot software. power the dobot and try to connect through the software.
maybe you are missing some connection settings?

besides that, do yout get a connection using the normal dobot firmware?


Thanks for your previous answer.

I’ll try to do what you suggest, however I don’t think the problem comes from the connection as I can properly connect. If the firmware is the Dobot_Studio, the red turns green. Once I burned the Repetier_host firmware, it becomes red. Also, I can control the fan speed in the 3D printing software, which is indeed happening properly on the Dobot. This seems to indicate that the connection is working as intended.