Dobot Arm suddenly not working


#1

My dobot is properly working, then suddenly I encountered this errors:

ERR_LIMIT_AXIS23_POS
ERR_LIMIT_AXIS3_NEG

Tried solutions:

  1. Parallelogram Positive Limitation Alarm - Quit the limitation area
  2. Executed script ClearAllAlarmsState
  3. Changed the usb port
  4. Reinstalled Dobot studio
  5. Reset Dobot Arm via reset button at the back
  6. Created new coordinates for home x, y, z, r, and set it to new home
  7. Rebooted dobot arm/Dobot studio
  8. Reattached peripherals while the dobot arm is turned off.

Does anyone encountered this errors? Thanks!


#2

I ever saw some users in the Dobot forum encountered similar problems.
They gave some solutions to this problem. You can visit the following link.
https://forum.dobot.cc/t/dobot-magician-runs-into-axis-limits-after-homing/2902


#3

Hello, I think the point you set has exceeded the Magician’s range of motion, and the problem can be solved by moving it away from the limit position.


#4

Hi,I have ever encountered this errors. After I re-burned the firmware, the problem was solved.
About re-burning the firmware manually, please visit the following link.


#5

I tried this solution and my dobot is already working fine :slight_smile: Thanks!