Cant update MOOZ-3 Firmware


I just received and built my MOOZ-3, and everything seems fine for from a hardware perspective. I was able to calibrate the printer and start a single-colour print. However, the colour mixing interface did not seem to work at all. When I looked again at the manual, I realised the UI pictures were quite different, so I checked what firmware version the printer was running.

The printer itself showed itself as running something like 0.4.1 (according to the touchscreen).

So, from the Dobot site, I downloaded:
Touchpad firmware for MOOZ-1/2/3 v1.1.0


MOOZ Firmware for MOOZ-3 v1.3.6

The touchpad firmware installed successfully via the SD card. However, the interface looks as though it’s intended for the MOOZ 1 and 2, despite the download description mentioning MOOZ-3 as well. It’s possible of course that the firmware is looking for some kind of signal from the printer controller firmware in order to determine what to show, but either way, the touchscreen can no longer operate the printer at all!

Updating the printer controller firmware has been less successful. When I insert the SD card with the MOOZ-3 v1.3.6 bin file, and power the printer on, I get the following message on the screen:

Baud: 9600
SD Card Update…
No Find File

So, at the moment, I can’t use the printer at all! I’ve emailed support, but haven’t heard back yet - I’m hoping I just need some alternative firmware. If anyone has any suggestions for what I might try in the meantime, I’m open to ideas! Here are some other things I’ve tried:

  • Connecting directly from the PC to the printer via USB, using a serial monitor, Arduino IDE, Repetier, and avrdude, in the hope that maybe I could control the printer hardware, or try uploading the firmware directly. However, I it’s possible the USB connection is actually to the touchscreen controller, not the printer controller. I didn’t get a useful connection.

  • Using different SD cards for the firmware, just in case.

  • Putting the firmware on a USB drive, since I was originally able to print from USB - printer didn’t recognise it.

  • Renaming the .bin file to a later version

Thanks in advance. Wish me luck! :slight_smile:


Has the problem been solved


No, the firmware simply won’t update - I just get that error message.


First determine if your version is Mooz3 or Mooz3plus. If it is Mooz3plus, you need to try another firmware.

Best Regards


I have also faced the same problem with my laptop. Every time I shut down my system, an update starts and the same thing happens during the time of starting up. I have searched a lot on the Internet for its fix, and finally, epson printer error code 0xf3 helped me a lot to solve the error.


I was also trying to update the firmware of my MOOZ but couldn’t do it as I was getting the same error as you. I was going to use it for some of my tasks on last minute paper writing service and would really like to try out the solutions you shared here to update the MOZ and use it.