can node defect



we have some problems with the dobot m1. I talked to the german service, they advise me to contact you . i installed everything and got a Connection to the m1.

In the messagewindow in the middle is the following displayed.


the can nodes didn.t response, i have made an messurement, the voltage between canH and CanL is 0.17 V, if i am right it should be 5.0V.

after that i updated

… the a9 system [was ok]

—then i updated

…the dobot firmware [was ok]
…3d printing firmware [was ok]
…fpga firmware [was ok]

Driver 1 [error update]
Driver 2 [boot failed]
Driver 3 [error update]
Driver 4 [boot failed]
Endeffector [error update]

if you have any idea how to fix the problem, give me some info please!
the m1 didn.t work from the beginning ;(. so it would be nice if it works in the future .

if you need some logs, or pics give some info!

kind regards


Please email to to get technical support, thanks


I also have this error. Straight from the box, the Dobot M1 has the exact same error. I tried updating the firmware, had almost the same error.

Dobot Firmware OK
EndEffecter Error Update
Driver1 Error Update
Driver2 Error Update
Driver3 Error Update
Driver4 Error Update

Is there a fix to this problem? This question was made October 2018. It is now May 2020. There should be a fix by now.